Equipamiento Cisco

COMANDOS CISCO

VLAN

Sobre Switch Catalyst 2924

Configuracion de VTP:

vlan database

vtp client

vtp domain

vtp password

Configuracion de los puertos trunk:

switchport trunk native vlan 200

switchport trunk encapsulation dot1q

Configuracion puertos de acceso:

interface fastethernet 0/1

switchport mode access

switchport access vlan21

Configuracion IP :

interface vlan 1

ip address 192.168.0.1 255.255.255.0

no shutdown

Otros:

show interface switchport

clock timezone UTC1

clock timezone CET 1 (En Europa)

ntp server 172.16.0.1

clock summer-time CET recurring last Sun Mar 2:00 last Sun Oct 3:00

CatOS

boot system flash bootflash:cat4500e-entservicesk9-mz.152-4.E7.bin

Monitorización del rendimiento

show processes cpu

show processes cpu history

show processes cpu sort

show platform health

clear counters

Comprobar estado del switch

#show environment

#show env temp

#show env status fan-tray

#show power

#show env status power-supply

Ver puertos que más datos transfieren

debug platform packet all count

show platform cpu packet statistics

show int | inc line protocol | packets/sec


Filtrado de Resultados de Comando show

R3#show running-config | ?

begin Begins unfiltered output of the show command with the first line

that contains the regular expression.

exclude Displays output lines that do not contain the regular expression.

include Displays output lines that contain the regular expression.

Ver procesos

show stp blockedports

show inventory

show platform cpu packet statistics all

Software de Análisis de comandos: Cisco CLI Analyzer

no local-proxy-arp

show platform health

monitor session 1 source interface fastethernet 5/1

monitor session 1 source vlan 1

monitor session 1 destination interface fastethernet 5/48


Configuracion de VTP:

set vtp domain ips

set vtp mode server

set vtp v2 enable

set vtp prunning enable

Configuracion de los puertos trunk:

set vlan 200 1/1 (Vlan Nativa)

set trunk 1/1 on dot1q 1-1005

Configuracion puertos de acceso:

set vlan 21 1/2

Configuración de un Etherchannel:

Switch2> enable

Switch2# configure terminal

Switch2(config)# interface range fasttethernet0/1 -2

Switch2(config-if-range)# switchport mode access

Switch2(config-if-range)# switchport access vlan 10

Switch2(config-if-range)# channel-group 2 mode auto "NOTA1"

Switch2(config-if-range)# end

NOTA1: en modo auto solo entra en etcherchannel si alguien se lo pide. En el otro extremo tiene que estar en desirable para que se active el sistema.

Nota: Las configuraciones relacionadas con el protocolo IP se hacen dentro del "interface channel-group 2"

Configuración IP del etherchannel:

  • interface port-channel 1

  • ip dhcp snooping trust

Para ver el estado del etherchannel están los siguientes comandos:

  • show interface port-channel 1

  • Show interface eterchannel

  • show etherchannel

  • sh etherchannel summary

  • show interface status

Configuracion IP:

set interface sc0 vlan 200 192.168.0.1 255.255.255.0 192.168.0.255

set interface sc0 vlan IP MASK BROADCAST

Creación NAT en Cisco 5500

Nombre del equipo:

hostname CDP_Router5500

Configuración del servidor DHCP:

ip dhcp excluded-address 172.20.0.1 172.20.0.100

ip dhcp pool LAN

network 172.20.0.0 255.255.0.0

default-router 172.20.0.1

dns-server 8.8.8.8

Creación de la parte interna del NAT con balanceo de carga:

#Configuración de las 2 líneas de salida, parte externa del NAT (WAN). Se aplican reglas del cortafuegos

interface Vlan19

ip address 192.168.100.7 255.255.255.0

ip access-group 101 out

ip nat outside

interface Vlan20

ip address 192.168.0.7 255.255.255.0

ip access-group 101 out

ip nat outside

#configuración de la parte interna del NAT (LAN)

interface Vlan21

ip address 172.20.0.1 255.255.0.0

ip nat inside

#Configuración del NAT

ip nat inside source route-map vodaf1 interface Vlan20 overload

ip nat inside source route-map vodaf2 interface Vlan19 overload

#Lista de acceso para la parte interna del NAT

access-list 100 permit ip 172.20.0.0 0.0.255.255 any

access-list 100 permit ip 192.168.202.0 0.0.0.255 any

#Asignación de la lista de acceso anterior al NAT y a las interfaces de salida

route-map vodaf2 permit 10

match ip address 100

match interface Vlan19

route-map vodaf1 permit 10

match ip address 100

match interface Vlan20

#Configuración del cortafuegos

access-list 101 deny tcp any any gt 1023

access-list 101 permit ip any any

#Definición de las rutas por defecto para el balanceo de carga, una para cada salida.

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip route 0.0.0.0 0.0.0.0 192.168.100.2

#Configuración de la sincronización y contraseña de la consola

line con 0

password cisco

logging synchronous

login

Comados show:

Ver historial de mensages de logging: show logging

show interfaces status err-disabled

#Ver listas de acceso: show access-list

#Ver historial Procesos: show processes cpu history

Cisco Catalyst 4507R

Borrar estadisticas de interfaces

#Clear counters

Gestión de alimentación PoE:

show power

show power inline

CISCO MERAKI

Empresa adquirida por Cisco en diciembre de 2012, cuyo software permite:

  • Administración 100% los dispositivos meraki de la red y de los equipos finales de los clientes

  • Facilitando la administración, ahorrando un tiempo significante en esta tarea.

  • Despligue rápido de la red y gran facilidad de actualización.

  • Licencia a 1, 2, 5, 7 ó 10 años, con soporte 24x7 y garantía de por vida en actualización y sustitución

  • Permite priorización de tráfico para conservar el ancho de banda

  • No necesita hardware extra

Webminar presentación

CISCO TRAINING

Global Training

Whireshark en Windows 10, no funciona

Ir a CMD como administrador y ejecutar "net start npf", luego reiniciar Whireshark y volverá a funcionar.